Über den Author / Internet / Server / Confixx / Confixx PHP 5.3 Probleme

Confixx PHP 5.3 Probleme

~0 Min. Lesezeit

Je nach welche Version von Confixx man betreibt, hat man Probleme mit PHP 5.3. Genauer sind alle Versionen von Confixx 3.3.6 oder älter betroffen.

Die Lösungen dazu liefert Parallels im KB8078 in 4 verschiedenen Fixes. Ich habe diese konsolidiert und mit folgenden Befehlen ist alles erledigt:

cd /root
wget http://www.murawski.ch/wp-content/uploads/2011/05/confixx_php5.3.patch
cd confixx
patch -p0 < /root/confixx_php5.3.patch cd /var/www/confixx patch -p1 < /root/confixx_php5.3.patch

Weiterhin hat Confixx auch Proleme mit der Erweiterung APC unter PHP 5.3, weshalb sich empfiehlt diese zu deinstallieren (falls nicht genutzt) oder für Confixx zu deaktivieren.

APC unter PHP 5.3 deinstallieren
Dies geht in dem man folgende Befehlen:

rm /etc/php5/conf.d/apc.ini
apt-get remove php5-apc

APC unter PHP 5.3 deaktivieren
Dies geht in dem man folgende Zeile in die confixx_mhost.conf setzt:

php_admin_value apc.enabled 0

Anschliessend muss der Apache2 neu gestartet werden und die Probleme sind Geschichte.

/etc/init.d/apache2 restart

About Stefan

Ein männlicher IT Nerd, durchstöbert das Web nach speziellen Gadgets, unentbehrlicher Software und Alles was man im IT Sektor nicht verpassen darf. Immer hilfsbereit wenn Probleme zu lösen sind oder das Unmögliche umgesetzt werden sollte.

Weitere interessante Artikel

Hibernate und Sleep nach Windows Update verschwunden

~0 Min. LesezeitWindows hats mal wieder gemacht, ein grosses Update, was viele Voreinstellungen einfach wieder …

WordPress Domain Suchen und ersetzen

~0 Min. Lesezeit Es gibt diverse Plugins für WordPress, welche die Datenbank durchsuchen und Domain Vorkommnisse ersetzen. Doch was, wenn das WordPress bereits nicht mehr aufrufbar ist, da eine Umstellung schief ging? Dazu sind Plugins nicht brauchbar. Aus diesem Grund stelle ich meine Domains, mit einem kleinen PHP Skript um, was ich hier vorstelle. Das Skript durchsucht nicht die komplette Datenbank, was viel zu aufwändig …

2 Kommentare

  1. Confixx 3.6.6… habe ich etwas verpasst? Mir sagt er, mein Confixx 3.3.7 pro SE sei die neuste Version … :? Ansonsten danke für den Patch, werde mal meinen neuen vServer überprüfen, was da so an PHP läuft ^^

  2. Danke, hab es korrigiert.